Урок 1.2. Препроцессор Sass. Исправление ошибки

Дата публикации: 31-07-2018

Препроцессор Sass

От автора: в данном видеоуроке вы увидите решение проблемы, которая связана с выходом новой версии Gulp и возникла при использовании команд для старой версии Gulp.

скачать урок

Все уроки курса:

Метки:

Комментарии (1)

  1. AlexU

    gulpfile.js

    const gulp = require(‘gulp’);
    const sass = require(‘gulp-sass’);
    const plumber = require(‘gulp-plumber’);
    const autoprefixer = require(‘gulp-autoprefixer’);
    const browserSync = require(‘browser-sync’).create();
    const sourceMaps = require(‘gulp-sourcemaps’);

    gulp.task(‘sass’, function () {
    return gulp.src(‘scss/style.scss’)
    .pipe(plumber())
    .pipe(sourceMaps.init())
    .pipe(sass())
    .pipe(autoprefixer())
    .pipe(sourceMaps.write())
    .pipe(gulp.dest(‘build/css’))
    .pipe(browserSync.reload({stream: true}));
    });

    gulp.task(‘html’, function () {
    return gulp.src(‘*.html’)
    .pipe(gulp.dest(‘build’))
    .pipe(browserSync.reload({stream: true}));
    });

    gulp.task(‘serve’, function () {
    browserSync.init({
    server: «build»
    });

    gulp.watch(«scss/**/*.scss», gulp.parallel(«sass»));
    gulp.watch(«*.html», gulp.parallel(«html»));
    });

    ВЫДАЁТ ОШИБКУ

    code: ‘MODULE_NOT_FOUND’,
    requireStack: [
    'C:\\Users\\User\\WebstormProjects\\sass\\gulpfile.js',
    'C:\\Users\\User\\AppData\\Roaming\\npm\\node_modules\\gulp-cli\\lib\\versioned\\^4.0.0\\index.js',
    'C:\\Users\\User\\AppData\\Roaming\\npm\\node_modules\\gulp-cli\\index.js',
    'C:\\Users\\User\\AppData\\Roaming\\npm\\node_modules\\gulp-cli\\bin\\gulp.js'
    ]
    }

Добавить комментарий