WordPress 5.6 станет неприятным сюрпризом для тысяч сайтов

WordPress 5.6 станет неприятным сюрпризом для тысяч сайтов

От автора: выпуск новой версии WordPress может привести к очередному коллапсу из-за нарушения работы плагинов, использующих устаревшие версии jQuery.

Эксперты считают, что новая версия WordPress (5.6), выпуск которой запланирован на декабрь текущего года, может вызвать повторение глобального сбоя. Он наблюдался в августе, когда после выхода WP 5.5 из-за удаления из ядра движка библиотеки jQuery Migrate была нарушена работа многих сайтов. Она позволяла темам и плагинам со старыми версиями jQuery работать в WordPress, использующем свежие версии библиотеки.

Тогда, чтобы восстановить работоспособность этих ресурсов, команда WordPress выпустила плагин Enable jQuery Migrate Helper. Но в WP 5.6 появится обновленная версия jQuery Migrate. Из-за этого плагин, которые базируется на более старых редакциях этой библиотеки, перестанет работать. А вслед за ним и все темы и плагины, которые используют старые версии jQuery.

Источник: www.searchenginejournal.com

JavaScript. Быстрый старт

Изучите основы JavaScript на практическом примере по созданию веб-приложения

Узнать подробнее

Основы создания тем WordPress

Научитесь создавать мультиязычные темы с нестандартной структурой страниц

Смотреть

Метки:

Похожие статьи:

Комментарии Вконтакте:

Комментарии Facebook:

Комментирование закрыто.